Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
OneUp V2 Build Log.
New Heating Element

Fire in the hole!

NOTE:  The following entry is around two weeks old.  I just got around to annotating/cropping/compressing the photos for it.

So, as mentioned, my previous entry had an error in it, which I will correct in this entry.

I did not get to work on the OneUp at Build Night.  Heck, I did not even get my car fixed, but I did a lot of work on it (the car, not the OneUp).

Anyway, working overtime, and just general hubris (is that the correct word?) kept me from messing with the OneUp directly.  I had been looking at the Marlin firmware files, and I noticed that I had set TEMP_SENSOR_0 back to 1 (100K) at some point.  This made no sense to me, as I needed it to be 0 (not used) in order to test the motors.

So, I finally started messing with the OneUp.  The heating element and the temperture sensor were both disconnected from the RAMPS 1.4 board, which was fine as I was replacing them anyway.  My first hurdle was the fact that in order to take up slack in these beasties I coiled the wires and used steel safety/lock wire as a sort of twist tie to keep the coils together.  For those not familiar with safety/lock wire, you use special safety wire pliers to twist them, and then you do NOT un-twist them.  The steel is too strong.  That is why it is called "lock" wire.


I was, however, able to simply uncoil the heating element by sliding its bare wires out of the safety wire wrap.  This gave enough slack/play within the rigid wrap to slide out the tempeature sensor's wire, with its plug.

Which brings me to a future hurdle:  The new temperature sensors do not have plugs, so I will have to cut the plug off the old sensor, and solder it to the new sensor.  The lack of a plug, however, made it easy for me to slip the wires back in the steel twist tie, along with the new heater wires, and coil both up nice and neat just like their predesessors.


I like the new heating elements in that the leads are semi-stripped.  The insulation is cut but not removed.  I removed the insulation, twisted up the strands and stuck them into the screw leads on the RAMPS board, and tightened down the screws.


Time for the correction:  Remember how I said that I never built the special resistor test plug?  Remember how I mentioned that the firmware was set back to a 100k sensor?  Well, I was considering plugging the old sensor in, when I discovered a 100K resistor plugged in to the the RAMPS board.  I *DID* build the resistor plug!  Now it all comes back to my failing memory.  My buddy Jack (not Jake, he's the Boy Wonder) brought in some old electronic odds and ends for me, which included something with the plug (which we cut off) and something that had a 100K resistor in it (which we removed, and soldered and shrink-wrapped to the plug).


I immediately fired everything up to see how it would work.  Sure enough, no errors.  Repetier-Host reported temperature at a constant, non-changing 24.4 degrees C.  Just what one would expect from a constant, non-changing resistor.

But still, no heat.  Not even from the new heating element.  I fumbled around in the software, until I found a button labelled "heat extruder."  Once I clicked this, the heating element immediately started generating heat.

At this point, I shut everything down, and declared another victory.

But, you don't get away from this story without learning something that I learned reading through the comments in Marlin's configuration.h file:

Tip:  The 100K resistor plug is completely useless.  Setting TEMP_SENSOR_0 to 998 or 999 does the exact same thing.  It simulates a temperature sensor at a constant reading (that is configured elsewhere in configuration.h).  All the same warnings that I made about the 100K resistor plug apply here.  It is not for actual printing.  It can cause fire, damage, death, etc.  It is not giving an actual reading as to what is happening out on your print head, so RAMPS may overheat the head, or do something stupid based on misinformation.  It is for testing your motors and extruder control only.

Been working overtime shifts, so do not know when I will get a chance to work more on this.  Stay tuned.
[Image: avatar_23.png?dateline=1515658171]
Extruder Plug Transplant

Progress, slow but sure...

NOTE: The following entry is about a week old.  Just when I start writing entries, again, we start having the hosting issues (grrrr...).  So, when I mention "Last week..." I actually mean two weeks ago, and when I say "...tomorrow's build night," I am actually talking about last week's build night, which I missed because I overslept and the radiator had not arrived until the next day, anyway...

Last week, as I waited for my car's engine to cool down, I cut the plug off the old extruder and soldered it on the new extruder.  I cut the plug far enough up the wire that I could just leave the label on there, so the wire is already labelled.  Some shrink wrap tubing finished off the job.



The rest of the night, I worked on my car.  All for naught, as it looks like I need a new radiator.  One is on order, and hopefully, it will be here by tomorrow's build night.

I really need to keep my car running.  It's sort of the priority at this point.
[Image: avatar_23.png?dateline=1515658171]
Configure Slic3r - Part I

There's more to it than meets the eye.

You learn something new every day.  Today I learned that the forum has a limit of five attachments per post.  Since this entry has nine screenshots, I have broken it down into two posts.

When I downloaded the software/firmware, it included a 200micronBASIC.ini file, which is a Slic3r Configuration File.

I figured there was really nothing to configuring Slic3r.  On initial start up, it threw a Configuration Wizard (CW) up in my face.


The CW had instructions that said if I had an *.ini file, I could simply cancel out of the CW, and select File->Open Config.

The option was actually File->Load Config...  But hey, It's the thought that counts.  Right?


I simply navigated the standard file dialog to the correct folder, selected the 200micronBASIC.ini file, and clicked "Open" in the lower right corner.


After that, I was unceremoniously dumped back at the main Slic3r screen, which I exited, as I did not even have my OneUp hooked up.


I thought it was configured.  It wasn't.

The correct procedure can be found in Configure Slic3r - Part II
[Image: avatar_23.png?dateline=1515658171]
Configure Slic3r - Part II

I wonder if this five attachment limit is part of the hosting issues?

There are actually a whole bunch of steps that need to be followed to configure Slic3r.  This is for version 1.2.9 in Linux, so hopefully it has gotten better.

First, even File->Load Config... was wrong, as there were multiple configuration items in the 200micronBASIC.ini file.  The correct selection was File->Load Config Bundle...


Same file dialog as before, same 200micronBASIC.ini selection.  This time, slightly different result:


But, poking around looking at the settings, they still do not match what the 200micronBASIC.ini file says.  Even exiting and restarting Slic3r does not help.  That is because I was not done with the configuration.

File->Preferences brings up a dialog that lets me choose a "Mode."  Default is "Simple."  We need "Expert" to finish the configuration.


Don't panic.  In expert mode, we are simply going to select three configurations, and let Slic3r do the heavy lifting for us.  Clicking OK induces a popup:


And NOW we can restart Slic3r.

Upon restart, there are now three new pick lists on the Plater tab.  These should all be set to "200micronBASIC".  They were not.  So I set them, exited, and restarted Slic3r.  They now come up as the defaults.


To further verify things.  I went to the Print Settings tab, and observed that the layer height/first layer height were 0.2/0.25 just as it is in the 200micronBASIC.ini file.  On the Filament Settings tab, I observed that the filament width changed from Slic3r's default of 3 to 1.74, just as it is in the 200micronBASIC.ini file.  On the Printer Settings Tab, I clicked on the Set button under "Bed Shape" and observed that the rectangular dimensions had changed from Slic3r's default of 200x200 to 175x175, just as it is in the 200micronBASIC.ini file.

At this point, I shut down and declared victory.

In other news, my radiator surgery was successful.  This may free up more build nights for playing with the OneUp.  And in case you are thinking that I am always having coolant issues with this car, last year the heater core was on my other car (which is currently down for other maintnence issues).

In any event, tune in next time for another thrilling step forward.  Same Bat-Forum, Same Bat-Thread.
[Image: avatar_23.png?dateline=1515658171]
Getting the Thermistor "In Place."

I knew I bought that metric hardware kit for something.

The heating block has a threaded hole in it.  This is where the screw (that secures the thermistor) screws in.

Right next to the hole is a little divot in the heating block.  This is where the thermistor head goes.

The head of the screw is supposed to be large enough to cover enough of the divot so that the thermistor head does not fall out of the divot.  The screw head is not large enough.

Q3D had a novel way to keep the head in place.  They routed each wire lead around opposite sides of the screw, tightened the screw down ridiculously tight, crushed the wires and damaged the thermistor.

Great job, guys!

Anyway, the solution seemed simple to me.  Get an M3 washer, just like I did for the adjustment screw on the extruder.  Just don't tighten the thing down, crazily.  Cover the hole.

Now, I was hoping for an M3 flat washer, but I did not have one of those on hand.  Instead, I checked my metric hardware kit that I bought at Rural King, a year or two ago.

The kit was still shrink wrapped.  I had never used it.  I SHOULD have taken it with me to work on my Toyota Radiator, as we were scrambling to find some fresh metric hardware (grrrrrr!).  But, that is now all a bridge underwater.

The smallest the kit went was M4, and they did not have flat washers.  They had split washers.

Strangely enough, the absolutely wrong hardware worked swimmingly.  Instead of a thick flat washer, it was almost like a coil of wire.  Because this "wire washer" was M4, it was actually spread out enough to cover the hole, but because it was a "wire washer" it was small enough not to cover the whole hole, and let the wire leads come out.

I would have taken pictures, but I am having problems with my smartphone right now.  It is taking a long time to charge.  When I get a chance, I will take some pics.

Stay tuned.
[Image: avatar_23.png?dateline=1515658171]
All Together Now

Just add some tape...

NOTE:  This post, and the next several posts, took place at Friday night's EAA Build night.

As promised, here is a close-up of the screw-with-washer.  Even close up, the washer looks almost invisible.


Anyway, I wanted some more support for the thermistor, as something tugging on that wire may break the head off, or something.  The original pieces parts were shrink-wrapped together, near the heads.


I did not have shrink wrap handy, but I did have Blue Painter's Tape (BPT), which will show up more prominently in the next entry.


So, I taped the thermistor wires to the heater wires.

Now, let's see if we can get this thing working with a real thermistor.
[Image: avatar_23.png?dateline=1515658171]

Now what?

Okay, get some Blue Painter's Tape (BPT) on the build surface, so prints do not stick to the surface forever.  Using a razor blade, I cut the edges nice and clean.


Next, un-level the print bed.

No, that is not a misprint.  It is time to un-level the print bed.  Usually, one tries to level the print bed.  However, the "stock" OneUp X-carriage has this serious "droop" on the right side.  A level print bed would either cause the print head to crash into the print bed (as it went right) or be too far away from the surface to properly lay down a layer (as it went left), or both.  In order to properly print, one needs the "crookedness" of the print bed to match the X-carriage's crookedness.

Of course, your prints will all be skewed (your alignment cube will look like a parallelagram from the side), but the printer will (theoretically) print, which is all I want at this point.

Time for an aside.

Aside:  I never knew what "auto bed leveling" was, until just a few days ago.  I always thought it used small steppers to adjust the screws on the bed corners, or something.  It doesn't.  Also called auto-tramming, it actually uses a sensor (near the print head) to "sense" the bed, figures out how screwed up your bed-to-Xcarriage-unparallelness is, and the firmware adjusts your print to "counterskew" everything so your print comes out right while your print head avoids crashing into the bed.

Anyway, back from the aside, I wouldn't mind hooking up a sensor to this whole thing, and using auto tramming/levelling to "fix" the droop problem.  There are multiple issues with this solution:
  • I don't have a sensor.
  • There's no place to mount the sensor where it does not "miss" the bed at one end/side/corner.
  • The best/cheapest solution would be an inductive sensor, which would require an aluminum (actually iron) print bed.
So, we are back to un-levelling.

Now, someday in the future, I still would not mind an inductive bed sensor.  I could 3d-Print the X-carriage bearing/extruder holder to have a sensor holder on it (behind the bearings, opposite the print head).  I could replace the stock bed with an aluminum plate (longer on the back side, so the sensor does not miss the bed).  Furthermore, I could mount heating elements and a thermistor on the backside of the aluminum plate, to create a heated print bed.

This is, of course, all pie-in-the-sky dreaming.  Right now, I have to un-level the print bed.

I had my procedure all thought up:
  • Tighten down the corner bed screws about five turns.
  • Manually move the print head to the front right corner (same as "homeing" the print head, except we are going right instead of left).
  • Lower the print head until one could barely slide a business card between the print head and the bed.
  • Manually move the print head all the way to the left.
  • Loosen the left front bed screw, allowing the spring to raise the left corner of the bed to meet the print head.  Stop at about a business card's thickness from the print head.
  • Manually move the print head all the way to the right.
  • Manually move the bed all the way to the back.  Make sure you do not crash the head into the bed doing so.
  • The print head should already be a business card's thickness away from the bed.  If not, tighten/loosen the back right screw to compensate.
  • Manually move the print head all the way to the left.
  • Loosen the left rear bed screw, allowing the spring to raise the left corner of the bed to meet the print head.  Stop at about a business card's thickness from the print head.
  • Finally, use the manual control panel in Repetier-Host/Pronterface to move the all the way forward, all the way right, all the way back, all the way left, and all the way forward again.
  • The head should not have contacted the surface during the moves, and you should now have the head at the home position.  Click the home buttons to let the Marlin firmware know that the print head is homed.
It was a disaster.

First, just about five turns is all I could get out of the screws before the springs were completely compressed, and could not go any further.

Second, I needed more than five turns differential between the left and right sides of the print bed.  I either need shorter screws/springs on the right side, or longer screws/springs on the left side.

I just cannot unlevel the print bed enough to compensate for the X-Carriage droop.  This is my impasse.

There are two permanent solutions to the X-Carriage droop.  The first is the Pulley System.  You should use a non-stretchy line, like kevlar thread.  I have that.  The solution I am conidering uses a guitar/ukelele tuning machine head to take up final slack/adjust on the right side.  I don't have one of those, but I live within walking distance of a music store called "Pianos 'n Stuff" (Who'd a thunk it?), where I can pick one up.

The second option is to completely replace the X-carriage with something 3D printed.  This pretty much requires me to replace the extruder as well.  There are many X-carriage solutions that use a Bowden-style extruder.  I want to stay direct, for now.  Forum member floridaservices has turned me on to a direct extruder  X-Carriage solution on Thingieverse.

Really, both solutions require that I get them 3D-printed, and I still have to make a decision.

Until then, I have other aspects of the OneUp to mess with.
[Image: avatar_23.png?dateline=1515658171]
Stand II

Stand in the place where you are...

As you remember from last year, I wanted to make my OneUp portable, and to that end, bolted it down on the stand where it currently sits.  I used thin plywood, and have no place to add handles.

I will not be removing my OneUp from this stand.  It all holds together rather nicely, and keeps the electronics board in place.  However, I plan to bolt the entire kitandkaboodle down to a 2x6 plank of lumber, and put drawer handles on there.

A possible future expansion is the addition of an "overhead" handle, made of perforated angle iron.  Even with the drawer handles on the base, I am sure at some point, some idiot will grab the thing from the top.  So, I might as well have a (sturdy) handle up there.


I found a piece of 2x6 scrap in my chapter's scrap pile, and Jake cut it to size.

I will be painting, drilling, and screwing screws into it in the near future.
[Image: avatar_23.png?dateline=1515658171]
Electronics Fully Functional (almost)

Sattenger's Law:  It works better if you plug it in.

So, with my stand plank cut, my BPT down, and my X-carriage horribly crooked, it was time to move on to the grand fallacy of build night:  Getting this thing to run Repetier-Host with an actual thermocouple.

First, the old laptop (that I use as my 3D printer server) had not been used in so long that the battery died, and the BIOS settings had reset.  So it would not boot Knoppix off the flash drive.  Okay, futz with the BIOS settings...

Then, I booted, Fired up Repetier-Host, and...

Nothing.  The heater would not heat up.

Okay, I remember seeing something on Amazon's site that for the NTC 3590, one used a value of 11 for TEMP_SENSOR_0.  I did not think this was significant, as the NTC 3590 is a 100K thermistor, and 1 is the setting for a 100K thermistor.  Maybe I was wrong.

Edit configuration.h, recompile, upload to Arduino, and...



So now, just to make sure SOMETHING works, I try moving the motors...

Dead.  The entire OneUp is dead.

Well, not the entire OneUp.  Repetier-Host can talk to RAMPS 1.4 just fine.  And, there is not even any error messages.  R.H. is sending commands, RAMPS is accepting them, and RAMPS reports back that everything is AOK.


I did not bring the resistor plug.  Maybe I could try that 997 configuration for TEMP_SENSOR_0...

Leave it to Jake (the Boy Wonder) to see the problem from the other side of the room.

"Uh, John, I'm looking at that switch that we installed on the back of your printer.  It doesn't look like it is turned on."

Uh, yeah.  <click>

Ah, there's the heater heating up.  Hey, the motors move real nice, now.  It works better when you turn it on  (which is a corollary to Sattenger's Law, quoted earlier).


Arduino can get its power from the USB port, so it was up and chatting away nicely with Repetier Host, and telling the RAMPS board to turn switches on and off.  The problem was:  The rest of the printer was completely dead without power, and RAMPS had no idea it was dead.

Electronics now fully functional?  Well, not quite.  One final test:  Run the extruder motor.

Could not get the thing to turn.

Finally, I swapped the extruder motor with the Z-axis motor.  This way, if I operated the Z-axis, and the extruder motor turned instead, I know the extruder motor is good.

The extruder motor *IS* good.

So, build night ends with a mystery as to why RAMPS 1.4 won't make the extruder motor go.  It's not the motor.  It's RAMPS/Repetier Host.

More to come.
[Image: avatar_23.png?dateline=1515658171]
Mystery No More

It's a grand slam!  Freakshow!  Freakshow!

I did not make it to build night, this week.  So I decided to play with the OneUp at home.

I looked over the Marlin Firmware, as I thought I saw something in there about a filament sensor (OneUp has no such sensor).  Nope.  Already commented out.  We're good-to-go.

Nothing left to do but try the thing out.  Wire everything up.  Boot the laptop.  And, turn on the OneUp.


Okay, Repetier Host is up.  Click connect.  Looking good.  Click "Heat Extruder."  Yep, everything coming up to temperature.

Okay, I am not in a good position to look into my extruder (don't have filament in there, yet), so I am just going to stick a finger in there and feel if that gear is turning.

Extruder manual control defaults to 10 mm.  Good enough.  I click the button.

I don't feel any movement, but damn, I swear I hear a motor turning.  Okay, now I have to reposition myself in order to see in there.

Click it again and...yes, there's movement.  It is turning...BACKWARDS!

If you remember my entry from last year, where I first got the X-Y-Z axes' motors running, I had to flip the electric connector on all three motors, but did not flip the extruder motor at that time, as I could not work the extruder motor until I fixed the heating element/thermocouple.

This completes the grand slam.  All four motors were wired up backward.  Flip the connector, and play some more.

Next, I try feeding my sample filament (that came from the kit) in there.  It broke off in my fingers.  Pretty dry and brittle, sitting around for a couple of years.  I put the little broken off piece in the extruder, and moved it forward and back - not far enough forward to heat it up in the extruder - just enough to test the mechanicals.

So now it looks like the only mystery is:  Why didn't it work last time?

Power down.  Declare another victory.

Currently, my X-carriage is some random height above the base of the OneUp.  I measured the random height at each end with a tape measure:

|Motor side:         |152mm|
|Free Side:          |146mm|
|Droop Differential: |  6mm|

So, my X-axis has over half a centimeter (a hair or two over a quarter of an inch) in droop.

During my running around, today, I stopped by my local big box store to pick up some M3 by 50 hex cap screws.  Of course, they only had 12 mm screws in the M3 size.  *Sigh*  I knew I should have went to the TrueValue hardware store in Sarver.  It is just that it is a haul to get out there, and I was doing a lot of other stuff.

So, once I get the screws/springs to unbalance the table, I might actually attempt to pump some plastic.

Stay tuned.
[Image: avatar_23.png?dateline=1515658171]

Forum Jump:

Users browsing this thread: 1 Guest(s)